re = /^(.*?)\s*((?:\((?:Case\b)?|\d+(?:\/\d+)?[A-Za-z]+\b).*)/m
str = 'Truly Mix 2/12Pk Cans - 12Z
Bud 16Z - LOOSE - 16Z
Blue Moon (Case 12x - 22Z)
2 for the show (6/4PK - 16Z)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end