using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\([0-9]*\))?\s*([^\,]*(\,)?)*";
string input = @"(1) Costume, (41) Hat, 1 Magic Wand Accessory";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}