$re = '/^(\([0-9]*\))?\s*([^\,]*(\,)?)*/m';
$str = '(1) Costume, (41) Hat, 1 Magic Wand Accessory';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);