re = /^(\([0-9]*\))?\s*([^\,]*(\,)?)*/m
str = '(1) Costume, (41) Hat, 1 Magic Wand Accessory'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end