import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"deviceSettings:segment\"):(\\{(?:\"\\w+\":(?:\\w+|\"[^\"]*\"|\\{[^\\}]*\\}|\\[[^\\]*]\\]),?)*\\})";
final String string = "{\"refs\":{\"deviceSettings:segment\":{\"id\":12345,\"enterpriseId\":12345,\"segmentObjectId\":null,\"data\":{\"segmentId\":0,\"delegate\":true,\"delegateProxy\":true}}}}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}