$re = '/("deviceSettings:segment"):(\{(?:"\w+":(?:\w+|"[^"]*"|\{[^\}]*\}|\[[^\]*]\]),?)*\})/';
$str = '{"refs":{"deviceSettings:segment":{"id":12345,"enterpriseId":12345,"segmentObjectId":null,"data":{"segmentId":0,"delegate":true,"delegateProxy":true}}}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);