use strict;
my $str = '{"refs":{"deviceSettings:segment":{"id":12345,"enterpriseId":12345,"segmentObjectId":null,"data":{"segmentId":0,"delegate":true,"delegateProxy":true}}}}';
my $regex = qr/("deviceSettings:segment"):(\{(?:"\w+":(?:\w+|"[^"]*"|\{[^\}]*\}|\[[^\]*]\]),?)*\})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}