re = /("deviceSettings:segment"):(\{(?:"\w+":(?:\w+|"[^"]*"|\{[^\}]*\}|\[[^\]*]\]),?)*\})/
str = '{"refs":{"deviceSettings:segment":{"id":12345,"enterpriseId":12345,"segmentObjectId":null,"data":{"segmentId":0,"delegate":true,"delegateProxy":true}}}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end