#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s?([\w\d,\.\-\|\s\:]+)"
Local $sString = "* [x] :cloud: capm3 :rocket: rke2 :penguin: suse" & @CRLF & _
"* [x] ☁ capm3 🚀 kadm 🐧 ubuntu" & @CRLF & _
"* [ ] ☁ capo 🚀 kadm 🐧 ubuntu 🟢 neuvector,mgmt:harbor" & @CRLF & _
"* [ ] ☁ capo 🚀 kadm 🐧 ubuntu :green_circle: neuvector,mgmt:harbor"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")