import re
regex = re.compile(r"\s?([\w\d,\.\-\|\s\:]+)", flags=re.MULTILINE)
test_str = ("* [x] :cloud: capm3 :rocket: rke2 :penguin: suse\n"
"* [x] ☁ capm3 🚀 kadm 🐧 ubuntu\n"
"* [ ] ☁ capo 🚀 kadm 🐧 ubuntu 🟢 neuvector,mgmt:harbor\n"
"* [ ] ☁ capo 🚀 kadm 🐧 ubuntu :green_circle: neuvector,mgmt:harbor")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")