import Foundation
let pattern = #"\s?([\w\d,\.\-\|\s\:]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
* [x] :cloud: capm3 :rocket: rke2 :penguin: suse
* [x] ☁ capm3 🚀 kadm 🐧 ubuntu
* [ ] ☁ capo 🚀 kadm 🐧 ubuntu 🟢 neuvector,mgmt:harbor
* [ ] ☁ capo 🚀 kadm 🐧 ubuntu :green_circle: neuvector,mgmt:harbor
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)