package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s?([\w\d,\.\-\|\s\:]+)`)
var str = `* [x] :cloud: capm3 :rocket: rke2 :penguin: suse
* [x] ☁ capm3 🚀 kadm 🐧 ubuntu
* [ ] ☁ capo 🚀 kadm 🐧 ubuntu 🟢 neuvector,mgmt:harbor
* [ ] ☁ capo 🚀 kadm 🐧 ubuntu :green_circle: neuvector,mgmt:harbor`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}