package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\-?\d*\.?\d{1,}?)$|^(\-?\.\d+)$`)
var str = `12
1.2
.12
12.12
-12
-1.2
-.12
-12.12
.1
.12
unwanted:
#12
“12
.12.
-.1.2
.
-.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}