// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\-?\d*\.?\d{1,}?)$|^(\-?\.\d+)$").unwrap();
let string = "12
1.2
.12
12.12
-12
-1.2
-.12
-12.12
.1
.12
unwanted:
#12
“12
.12.
-.1.2
.
-.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}