re = /^(\-?\d*\.?\d{1,}?)$|^(\-?\.\d+)$/m
str = '12
1.2
.12
12.12
-12
-1.2
-.12
-12.12
.1
.12
unwanted:
#12
“12
.12.
-.1.2
.
-.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end