$re = '/^(\-?\d*\.?\d{1,}?)$|^(\-?\.\d+)$/m';
$str = '12
1.2
.12
12.12
-12
-1.2
-.12
-12.12
.1
.12
unwanted:
#12
“12
.12.
-.1.2
.
-.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);