using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!___)(.+?)___|___|(?!___)(.+)";
string input = @"foo$12___bar___$34wilma buzz
hello$ there 12 h___uhuhu$12 otherstuff
test:$444$44ahahaHA$4$$34
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}