const regex = /(?!___)(.+?)___|___|(?!___)(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!___)(.+?)___|___|(?!___)(.+)', 'gm')
const str = `foo\$12___bar___\$34wilma buzz
hello\$ there 12 h___uhuhu\$12 otherstuff
test:\$444\$44ahahaHA\$4\$\$34
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}