re = /(?!___)(.+?)___|___|(?!___)(.+)/m
str = 'foo$12___bar___$34wilma buzz
hello$ there 12 h___uhuhu$12 otherstuff
test:$444$44ahahaHA$4$$34
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end