import re
regex = re.compile(r"(?!___)(.+?)___|___|(?!___)(.+)", flags=re.MULTILINE)
test_str = ("foo$12___bar___$34wilma buzz\n"
"hello$ there 12 h___uhuhu$12 otherstuff\n"
"test:$444$44ahahaHA$4$$34\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")