# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\S)[^\S\n]*(\n)/$1<br><br>$2/gm;t' <<< "
There are spaces at the end of line
No space at the end of line
"