import Foundation
let pattern = #"(\S)[^\S\n]*(\n)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
There are spaces at the end of line
No space at the end of line
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1<br><br>$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)