import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S)[^\\S\\n]*(\\n)";
final String string = "\n"
+ "There are spaces at the end of line\n\n"
+ " \n\n"
+ "No space at the end of line\n";
final String subst = "$1<br><br>$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}