#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\b(?!.*\.{2})[a-zA-Z.]+(?: [a-zA-Z.]+)\b$"
Local $sString = "Matched:" & @CRLF & _
"S. Something" & @CRLF & _
"S .Something" & @CRLF & _
"Not matched:" & @CRLF & _
" " & @CRLF & _
" ... " & @CRLF & _
"S.. Something"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")