re = /^\b(?!.*\.{2})[a-zA-Z.]+(?: [a-zA-Z.]+)\b$/m
str = 'Matched:
S. Something
S .Something
Not matched:
...
S.. Something'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end