$re = '/^[-\d](?:-|\B\d){4}[A-Z\d-]*$/m';
$str = '12345ABC
12345123
1234-1
1234--1
1----1AB
-----
--1--BB
----1-
1-1--11
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);