import re
regex = re.compile(r"^[-\d](?:-|\B\d){4}[A-Z\d-]*$", flags=re.MULTILINE)
test_str = ("12345ABC\n"
"12345123\n"
"1234-1\n"
"1234--1\n"
"1----1AB\n"
"-----\n"
"--1--BB\n"
"----1-\n"
"1-1--11\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")