re = /^[-\d](?:-|\B\d){4}[A-Z\d-]*$/m
str = '12345ABC
12345123
1234-1
1234--1
1----1AB
-----
--1--BB
----1-
1-1--11
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end