#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^([A-Y])?\s*(\d{0,4})\s?([a-d])?)|(?:^((?:\w+)|(?:\w+,)|(?:\w+, \w*))?\s*((?:&{1,2}|and|or|\|{2})\s+(?:.*)*)*)" & @CRLF & _
"" & @CRLF & _
""
Local $sString = "thra" & @CRLF & _
"" & @CRLF & _
"^\s*((?:\w+)(?:,?\s?)(?:,\s\w+\s*)*)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"^\s*?((?:\w+){1}\s*(?:(?:,?)|(?:,\s\w+))*\s*)" & @CRLF & _
"" & @CRLF & _
"\s*((?:&{1,2}|and|or|\|{2})\s+(?:.*)*)*" & @CRLF & _
"" & @CRLF & _
"(?:^([A-Y] +)*(\d{0,4}) ?(a-d))|"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")