re = /(?:^([A-Y])?\s*(\d{0,4})\s?([a-d])?)|(?:^((?:\w+)|(?:\w+,)|(?:\w+, \w*))?\s*((?:&{1,2}|and|or|\|{2})\s+(?:.*)*)*)
/m
str = 'thra
^\\s*((?:\\w+)(?:,?\\s?)(?:,\\s\\w+\\s*)*)
^\\s*?((?:\\w+){1}\\s*(?:(?:,?)|(?:,\\s\\w+))*\\s*)
\\s*((?:&{1,2}|and|or|\\|{2})\\s+(?:.*)*)*
(?:^([A-Y] +)*(\\d{0,4}) ?(a-d))|'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end