const regex = /(?:^([A-Y])?\s*(\d{0,4})\s?([a-d])?)|(?:^((?:\w+)|(?:\w+,)|(?:\w+, \w*))?\s*((?:&{1,2}|and|or|\|{2})\s+(?:.*)*)*)
/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^([A-Y])?\\s*(\\d{0,4})\\s?([a-d])?)|(?:^((?:\\w+)|(?:\\w+,)|(?:\\w+, \\w*))?\\s*((?:&{1,2}|and|or|\\|{2})\\s+(?:.*)*)*)
', 'gm')
const str = `thra
^\\s*((?:\\w+)(?:,?\\s?)(?:,\\s\\w+\\s*)*)
^\\s*?((?:\\w+){1}\\s*(?:(?:,?)|(?:,\\s\\w+))*\\s*)
\\s*((?:&{1,2}|and|or|\\|{2})\\s+(?:.*)*)*
(?:^([A-Y] +)*(\\d{0,4}) ?(a-d))|`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}