import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\d]*)(.|,)[\\d](e|E)[\\d]+";
final String string = "Valid floating points:\n"
+ "1\n"
+ "+1\n"
+ "-1\n"
+ "65\n"
+ "+65\n"
+ "-65\n"
+ "5.2\n"
+ "5,2\n"
+ "5.225\n"
+ "5,225\n"
+ "985.225\n"
+ "985,225\n"
+ "985.\n"
+ ",225\n"
+ "+5.2\n"
+ "+5,2\n"
+ "+5.225\n"
+ "+5,225\n"
+ "+985.225\n"
+ "+985,225\n"
+ "+985.\n"
+ "+,225\n"
+ "-5.2\n"
+ "-5,2\n"
+ "-5.225\n"
+ "-5,225\n"
+ "-985.225\n"
+ "-985,225\n"
+ "-985.\n"
+ "-,225\n"
+ "5.2E3\n"
+ "5.2e3\n"
+ "+5.2e3\n"
+ "-5.2e3\n"
+ "5,2E3\n"
+ "5,2e3\n"
+ "-5,2e3\n"
+ "+5,2e3\n"
+ "5.2e112\n"
+ "+5.2e112245\n"
+ "-5.2e99999\n"
+ "5,2e112\n"
+ "-5,2e112245\n"
+ "+5,2e99999\n"
+ "5.2e+3\n"
+ "+5.2e+3\n"
+ "-5.2e+3\n"
+ "5,2e-3\n"
+ "-5,2e-3\n"
+ "+5,2e-3\n"
+ "5.e3\n"
+ "5.e+3\n"
+ "+5.e+3\n"
+ "-5.e+3\n"
+ "5,e-3\n"
+ "-5,e-3\n"
+ "+5,e-3\n"
+ ",225e123\n"
+ "+,225e123\n"
+ "-,225e123\n"
+ ".225e123\n"
+ "+.225e123\n"
+ "-.225e123\n\n"
+ "Not floating points\n"
+ ",\n"
+ ",\n"
+ ",\n"
+ ".\n"
+ ".\n"
+ ".\n"
+ ".e\n"
+ ",e\n"
+ ".e2\n"
+ ",e2\n"
+ ",225e\n"
+ "+,225e\n"
+ "-,225e\n"
+ ".225e\n"
+ "+.225e\n"
+ "-.225e";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}