# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([\d]*)(.|,)[\d](e|E)[\d]+"
test_str = ("Valid floating points:\n"
"1\n"
"+1\n"
"-1\n"
"65\n"
"+65\n"
"-65\n"
"5.2\n"
"5,2\n"
"5.225\n"
"5,225\n"
"985.225\n"
"985,225\n"
"985.\n"
",225\n"
"+5.2\n"
"+5,2\n"
"+5.225\n"
"+5,225\n"
"+985.225\n"
"+985,225\n"
"+985.\n"
"+,225\n"
"-5.2\n"
"-5,2\n"
"-5.225\n"
"-5,225\n"
"-985.225\n"
"-985,225\n"
"-985.\n"
"-,225\n"
"5.2E3\n"
"5.2e3\n"
"+5.2e3\n"
"-5.2e3\n"
"5,2E3\n"
"5,2e3\n"
"-5,2e3\n"
"+5,2e3\n"
"5.2e112\n"
"+5.2e112245\n"
"-5.2e99999\n"
"5,2e112\n"
"-5,2e112245\n"
"+5,2e99999\n"
"5.2e+3\n"
"+5.2e+3\n"
"-5.2e+3\n"
"5,2e-3\n"
"-5,2e-3\n"
"+5,2e-3\n"
"5.e3\n"
"5.e+3\n"
"+5.e+3\n"
"-5.e+3\n"
"5,e-3\n"
"-5,e-3\n"
"+5,e-3\n"
",225e123\n"
"+,225e123\n"
"-,225e123\n"
".225e123\n"
"+.225e123\n"
"-.225e123\n\n"
"Not floating points\n"
",\n"
",\n"
",\n"
".\n"
".\n"
".\n"
".e\n"
",e\n"
".e2\n"
",e2\n"
",225e\n"
"+,225e\n"
"-,225e\n"
".225e\n"
"+.225e\n"
"-.225e")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.