using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"S\/?u?\/?n?\/?r?\/?i?\/?s?\/?e?";
string input = @"S/Su/Sun/Sunr/Sunri/Sunris/Sunrise";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}