re = /S\/?u?\/?n?\/?r?\/?i?\/?s?\/?e?/m
str = 'S/Su/Sun/Sunr/Sunri/Sunris/Sunrise'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end