package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)S\/?u?\/?n?\/?r?\/?i?\/?s?\/?e?`)
var str = `S/Su/Sun/Sunr/Sunri/Sunris/Sunrise`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}