package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{1,2} [A-Z][a-z]{2} \d{4} \d{2}:\d{2}:\d{2}`)
var str = `23 Aug 2019 05:26:53`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}