import re
regex = re.compile(r"\d{1,2} [A-Z][a-z]{2} \d{4} \d{2}:\d{2}:\d{2}", flags=re.MULTILINE)
test_str = "23 Aug 2019 05:26:53"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")