$re = '/\d{1,2} [A-Z][a-z]{2} \d{4} \d{2}:\d{2}:\d{2}/m';
$str = '23 Aug 2019 05:26:53';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);