// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{1,2} [A-Z][a-z]{2} \d{4} \d{2}:\d{2}:\d{2}").unwrap();
let string = "23 Aug 2019 05:26:53";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}