#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?i)[a-z-0-9‑]*?(?:plang|anlag|invest|warn|info|zukunft|design|enk|infra|insta|mënsch|liewens|vinyl|finnl|onge|längt|maintenance|dank|tank|vereinfach|einfach|fanger|gung|reng|keng|telefo|termin|ioun|immun|schwenk|nsl|lang|laang)[a-z-0-9‑]*?nn?[bcfgj-mp-sv-y](?!(chaft|ormatio|initi|eg(t|ung|e|s|itiv)))"
Local $sString = "MATCH:" & @CRLF & _
"" & @CRLF & _
"nonsense|waning|cannnnns|banger|fancy" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"NO MATCH:" & @CRLF & _
"" & @CRLF & _
"plang|anlag|invest|warn|zukunft|design|mënsch|längt|telefo|termin|ioun|immun" & @CRLF & _
"" & @CRLF & _
"plangens " & @CRLF & _
"pplang|clanlags|infrared|amazukunft" & @CRLF & _
"" & @CRLF & _
"cannon|wand|hone|banana" & @CRLF & _
"" & @CRLF & _
"BUT: Zukunftsunpassung (should match 'unpass' but not 'zukunft' and not 'ung')" & @CRLF & _
"Eegenschaftsunklang (should match 'Unkl' but not 'Eegenschaft' and not 'klang')"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")