import Foundation
let pattern = #"\b(?i)[a-z-0-9‑]*?(?:plang|anlag|invest|warn|info|zukunft|design|enk|infra|insta|mënsch|liewens|vinyl|finnl|onge|längt|maintenance|dank|tank|vereinfach|einfach|fanger|gung|reng|keng|telefo|termin|ioun|immun|schwenk|nsl|lang|laang)[a-z-0-9‑]*?nn?[bcfgj-mp-sv-y](?!(chaft|ormatio|initi|eg(t|ung|e|s|itiv)))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
MATCH:
nonsense|waning|cannnnns|banger|fancy
NO MATCH:
plang|anlag|invest|warn|zukunft|design|mënsch|längt|telefo|termin|ioun|immun
plangens
pplang|clanlags|infrared|amazukunft
cannon|wand|hone|banana
BUT: Zukunftsunpassung (should match 'unpass' but not 'zukunft' and not 'ung')
Eegenschaftsunklang (should match 'Unkl' but not 'Eegenschaft' and not 'klang')
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)