# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?i)[a-z-0-9‑]*?(?:plang|anlag|invest|warn|info|zukunft|design|enk|infra|insta|mënsch|liewens|vinyl|finnl|onge|längt|maintenance|dank|tank|vereinfach|einfach|fanger|gung|reng|keng|telefo|termin|ioun|immun|schwenk|nsl|lang|laang)[a-z-0-9‑]*?nn?[bcfgj-mp-sv-y](?!(chaft|ormatio|initi|eg(t|ung|e|s|itiv)))"
test_str = ("MATCH:\n\n"
"nonsense|waning|cannnnns|banger|fancy\n\n\n"
"NO MATCH:\n\n"
"plang|anlag|invest|warn|zukunft|design|mënsch|längt|telefo|termin|ioun|immun\n\n"
"plangens \n"
"pplang|clanlags|infrared|amazukunft\n\n"
"cannon|wand|hone|banana\n\n"
"BUT: Zukunftsunpassung (should match 'unpass' but not 'zukunft' and not 'ung')\n"
"Eegenschaftsunklang (should match 'Unkl' but not 'Eegenschaft' and not 'klang')")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.