import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?i)[a-z-0-9‑]*?(?:plang|anlag|invest|warn|info|zukunft|design|enk|infra|insta|mënsch|liewens|vinyl|finnl|onge|längt|maintenance|dank|tank|vereinfach|einfach|fanger|gung|reng|keng|telefo|termin|ioun|immun|schwenk|nsl|lang|laang)[a-z-0-9‑]*?nn?[bcfgj-mp-sv-y](?!(chaft|ormatio|initi|eg(t|ung|e|s|itiv)))";
final String string = "MATCH:\n\n"
+ "nonsense|waning|cannnnns|banger|fancy\n\n\n"
+ "NO MATCH:\n\n"
+ "plang|anlag|invest|warn|zukunft|design|mënsch|längt|telefo|termin|ioun|immun\n\n"
+ "plangens \n"
+ "pplang|clanlags|infrared|amazukunft\n\n"
+ "cannon|wand|hone|banana\n\n"
+ "BUT: Zukunftsunpassung (should match 'unpass' but not 'zukunft' and not 'ung')\n"
+ "Eegenschaftsunklang (should match 'Unkl' but not 'Eegenschaft' and not 'klang')";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}