import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(#.+?#)([^#]+)(#.*)";
final String string = "#4 MyApp\\Framework\\DB\\Adapter\\Pdo\\Mysql->_query('SELECT `store_we...', array()) called at [vendor/myapp/framework/DB/Adapter/Pdo/Mysql.php:621]\n\n"
+ "#5 MyApp\\Framework\\DB\\Adapter\\Pdo\\Mysql->query(MyApp\\Framework\\DB\\Select#b8e969b2c2d6#, array()) called at [vendor/myapp/zendframework1/library/Zend/Db/Adapter/Abstract.php:737]\n\n"
+ "#6 Zend_Db_Adapter_Abstract->fetchAll(MyApp\\Framework\\DB\\Select#b8e969b2c2d6#) called at [vendor/myapp/module-store/App/Config/Source/RuntimeConfigSource.php:87]";
final String subst = "\\1StaticText\\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}