use strict;
my $str = '#4 MyApp\\Framework\\DB\\Adapter\\Pdo\\Mysql->_query(\'SELECT `store_we...\', array()) called at [vendor/myapp/framework/DB/Adapter/Pdo/Mysql.php:621]
#5 MyApp\\Framework\\DB\\Adapter\\Pdo\\Mysql->query(MyApp\\Framework\\DB\\Select#b8e969b2c2d6#, array()) called at [vendor/myapp/zendframework1/library/Zend/Db/Adapter/Abstract.php:737]
#6 Zend_Db_Adapter_Abstract->fetchAll(MyApp\\Framework\\DB\\Select#b8e969b2c2d6#) called at [vendor/myapp/module-store/App/Config/Source/RuntimeConfigSource.php:87]';
my $regex = qr/(#.+?#)([^#]+)(#.*)/mp;
my $subst = '\\1StaticText\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";