import re
regex = re.compile(r"(#.+?#)([^#]+)(#.*)", flags=re.MULTILINE)
test_str = ("#4 MyApp\\Framework\\DB\\Adapter\\Pdo\\Mysql->_query('SELECT `store_we...', array()) called at [vendor/myapp/framework/DB/Adapter/Pdo/Mysql.php:621]\n\n"
"#5 MyApp\\Framework\\DB\\Adapter\\Pdo\\Mysql->query(MyApp\\Framework\\DB\\Select#b8e969b2c2d6#, array()) called at [vendor/myapp/zendframework1/library/Zend/Db/Adapter/Abstract.php:737]\n\n"
"#6 Zend_Db_Adapter_Abstract->fetchAll(MyApp\\Framework\\DB\\Select#b8e969b2c2d6#) called at [vendor/myapp/module-store/App/Config/Source/RuntimeConfigSource.php:87]")
subst = "\\1StaticText\\3"
result = regex.sub(subst, test_str)
if result:
print(result)