import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!(\\s?)\\S+:((?<quotetag>[\"']).*?\\k<quotetag>|\\(.*?\\)|.*?(?=\\s)|.*))((?<quote>[\"']).*?\\k<quote>)";
final String string = "sm:\"sidudhusdh\" eui:(duish iusds \"sidus d\" skdjhs) \n"
+ "th sdh dfj \" dfhd'jf 'ue \" dhfdf sdlsjdklsj \"djs dsh:djshd disdh:'djksdhjs' djshjdh:(djhsjds 'kdhjkd') hd s\"dfjlshds ";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}