const regex = /(?<!(\s?)\S+:((?<quotetag>["']).*?\k<quotetag>|\(.*?\)|.*?(?=\s)|.*))((?<quote>["']).*?\k<quote>)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!(\\s?)\\S+:((?<quotetag>["\']).*?\\k<quotetag>|\\(.*?\\)|.*?(?=\\s)|.*))((?<quote>["\']).*?\\k<quote>)', 'ig')
const str = `sm:"sidudhusdh" eui:(duish iusds "sidus d" skdjhs)
th sdh dfj " dfhd'jf 'ue " dhfdf sdlsjdklsj "djs dsh:djshd disdh:'djksdhjs' djshjdh:(djhsjds 'kdhjkd') hd s"dfjlshds `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}