re = /(?<!(\s?)\S+:((?<quotetag>["']).*?\k<quotetag>|\(.*?\)|.*?(?=\s)|.*))((?<quote>["']).*?\k<quote>)/i
str = 'sm:"sidudhusdh" eui:(duish iusds "sidus d" skdjhs)
th sdh dfj " dfhd\'jf \'ue " dhfdf sdlsjdklsj "djs dsh:djshd disdh:\'djksdhjs\' djshjdh:(djhsjds \'kdhjkd\') hd s"dfjlshds '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end